System Requirements for Website Builder

Web

All you need is a modern* web browser and an internet connection.

Supported Operating Systems:

  • Windows 10 and above
  • Mac OSX

*Supported Browsers:

  • Google Chrome: latest version *Recommended 
  • Mozilla Firefox: latest version
  • Apple Safari: latest version
  • Microsoft Edge: latest version
  • Internet Explorer is not supported

iOS

  • Requires iOS 10.0 or later. Compatible with iPhone, iPad, and iPod touch.

Android

  • Android 5.0 or later. 
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.